Warning

This version of ScalarDB is no longer supported. We recommend that you update to the latest version of ScalarDB.

Scalar DB Supported Databases

Scalar DB supports the following databases and the databases that are compatible with those databases.

  • Cassandra
  • Cosmos DB
  • DynamoDB
  • MySQL
  • PostgreSQL

Compatibility matrix

Scalar DB Version Cassandra 3.11 Cassandra 3.0 Cassandra 2.2 Cosmos DB DynamoDB MySQL 8.0 MySQL 5.7 PostgreSQL 13 PostgreSQL 12 PostgreSQL 11 Oracle 19.0.0.0.ru-2021-04.rur-2021-04.r1 Oracle 12.2.0.1.ru-2021-04.rur-2021-04.r1 Oracle 12.1.0.2.v24
Scalar DB 3.1.0
Scalar DB 3.0.0
Scalar DB 2.4.1
Scalar DB 2.3.0
Scalar DB 2.2.2
Scalar DB 2.1.0
Scalar DB 2.0.1